
TINY 
WITH ARDUINO 



 

 

All the lessons in this course are centered around the Arduino programming 

language, providing a comprehensive and hands-on approach to learning. By engaging 

with Arduino, you will gain practical experience in coding, electronics, and hardware 

integration, fostering a deep understanding of programming concepts and real-world 

applications. 

 

 

 

 

Installing Arduino Software 
 

 Download one of the below versions of Arduino software to your 

computer from the below link. Select the correct option according your 

computer OS type ( Windows , Mac or Linux ) 

 

o Version 1.8.19 

 

o Version 2.3.2 Note :- Magicbit Tiny doesn’t support Arduino latest versions (2.3.3 and 

2.3.4 ) 

 
o Download Arduino from here - https://www.arduino.cc/en/software 

 

 Install the downloaded software in your computer. 

Open the Arduino IDE from the shortcut created on your computer desktop. 
 

https://www.arduino.cc/en/software


 

Adding the Magicbit Tiny board to Arduino IDE 

 Connect the Magicbit Tiny board to the computer using the USB cable. 
 

 

 Open the “Preferences’’ window of the Arduino IDE as follows. 

File > Preferences 

 

 

Copy the below given release link and paste it on the “Additional 

Board Manager’’. Here you can paste multiple release links by 

separating them by “ , “. 

Release Link for Magicbit Tiny: https://magicbit.cc/boards/magicbit.json 

https://magicbit.cc/boards/magicbit.json


 

 

 

 Now open the “Boards Manger” window as in below path. 

 

Tools > Board > Boards Manager 
 

 Search as “Magicbit Tiny’’ and click on the “INSTALL’’ button to install it. 

This will take few minutes. 
 

 

 



 

 After installing, connect with the Magicbit Tiny board as follows. 

 

Tools > Boards > Magicbit Tiny > Magicbit Tiny 

 

 Then select the relevant USB port which the Magicbit Tiny is connected. 

 

Tools > Port > COM 

 

Now you are ready to program the Magicbit Tiny. 
 

 

 
 

 
 

Note :- If you don’t get the COM port to select or it doesn’t appear, You need to update 

the drivers of your computer. 

 

o Get into Magicbit Web Uploader and download the    drivers file in “Install 

Drivers” tab. 

o Install the downloaded driver and check for the COM port.  

o Unplug the USB cable and also reload the Arduino IDE. 
 

 

Add uploader image and highlight Install drivers tab



 

 
 

01. Light Show 
 

Create a LED Light Pattern using the on-board LEDs 

 

 Expected Output 

 

o https://youtu.be/J8UhgEjXZqg 

 

 Description 

 

o The LED light pattern project is a captivating display of sequential LED 

lighting using the Magicbit Tiny Board. With a simple array of digital output 

pins and a defined time delay, this project creates an eye-catching back-and- 

forth movement of LEDs. The speed and pattern of the LED chaser can be 

easily customized for various visual effects. 

 

 

o In Magicbit tiny has four in-built LEDs that can be programmed. These four 

LEDs have four different colors. 

 

https://youtu.be/J8UhgEjXZqg


 

Define the pins of the LEDs as an array 

 

 

Define the speed of the pattern 

 

The speed of the LED chaser is controlled by the ̀ timer` variable, 

allowing users to adjust the delay between each step and customize the 

visual effect. 
 

- Increase the timer to decrease the speed. 

- Decrease the timer value to increase the speed. 

 

Configure Magicbit tiny pin numbers 4, 5, 10, and 11 as outputs 

 

Forward and Backward LED chaser light patterns 
 

 

Full Program 

Download the program code from here 

 

 

 

 

https://drive.google.com/file/d/19N45Jod0tNHS2KaKV0NAAlqlF_rQGmhb/view?usp=sharing%20


 

Follow the steps below to upload example code for project light pattern. 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. Then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select Port -> COM<your port number> 

5. Type or copy and paste the above Arduino code to your new sketch 

and upload the code. 

Once uploaded, the Magicbit Tiny Board will execute the LED light pattern, 

creating a mesmerizing back-and-forth movement of lights. 

 

Experiment with different LED configurations, change the order of pin 

connections, or adjust the `timer` variable to create unique and visually 

appealing LED chaser effects. 

 

If you need the same activity in Sinhala Medium, go through the below Video. 

 

 

Tutorial in Sinhala - https://youtu.be/sE5F5A8FOQA 

 

https://youtu.be/sE5F5A8FOQA


 

 
 

02. Dimmer Magic 
 

Create a program to control the brightness of the LEDs using the 

Potentiometer in the Magicbit Tiny. 

 

 Expected Output 

 

o https://youtu.be/LWfj0KK7BGE 

 

 Description 

 

o The LED Dimmer project allows us to control the brightness of LEDs using 

a potentiometer. By turning the potentiometer, we can increase or decrease 

the intensity of the light emitted by the LEDs. 

 

 

 

 

 

 

 

 How it works 

 

o Potentiometer Input: The potentiometer, connected to pin A3 on the 

Magicbit Tiny board, acts as our brightness controller. Rotating the 

potentiometer wheel generates different analog values. 

 

o LED Brightness Control: The analog value from the potentiometer is mapped 

to a range of 0 to 255. This mapped value represents the brightness level. 

 

 

o LED Pins Configuration: LEDs are connected to digital pins 4, 5, 10, and 11. 

These pins will receive the analog value and adjust the brightness of the 

connected LEDs accordingly. 

https://youtu.be/LWfj0KK7BGE


 

 Steps for the Program 

 

 

Define the component pins 

 

 

Configure the pins 

 

 

Get the potentiometer reading, map the values and update the pattern 

 

 

Full Program 

Download the program code from here 

 

 

 

https://drive.google.com/file/d/1PADC96HsQxn5axROqFJ9ZggRy-LnxAZH/view?usp=sharing


 

Follow the steps below to upload example code for project dimmer 

magic. 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste above Arduino code to your new sketch 

and upload the code 

 

After uploading the code. 

1. Rotate the potentiometer wheel clockwise to increase brightness. 

2. Rotate the potentiometer wheel counterclockwise to decrease 

brightness. 

 

Learning Points: 

o Analog Input: Understanding analog values from the potentiometer. 

o Mapping Values: Learn how to map analog values to a specific range 

(0 to 255). 

Syntax 

o map(value, fromLow, fromHigh, toLow, toHigh) 

 

Parameters 

o value: the number to map. 

o fromLow: the lower bound of the value’s current range. 

o fromHigh: the upper bound of the value’s current range. 

o toLow: the lower bound of the value’s target range. 

o toHigh: the upper bound of the value’s target range 

 



 

PWM Output: Explore the concept of Pulse Width Modulation (PWM) for 

LED brightness control. 

 

After a call to analogWrite(), the pin will generate a steady rectangular 

wave of the specified duty cycle until the next call to analogWrite() (or a 

call to digitalRead() or digitalWrite()) on the same pin. 

 

Try to make diffrent light paterns by controlling the LED brightness. 

Have fun exploring the world of LEDs and brightness control with the LED 

Dimmer project! 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

 

Tutorial in Sinhala - https://youtu.be/dr9HBz4XL8g  

https://youtu.be/dr9HBz4XL8g


 

 
ACTIVITY 03 

03. Melody Magic 
 

Create a program to play musical tones using the buzzer in the Magicbit Tiny. 
 

 

 Expected Output 

 

o https://youtu.be/emDmRRFRifw 

 

 Description 

 

o Welcome to the magical world of melodies with the Magicbit Tiny Melody 

project! This fun and interactive project will introduce you to the basics of 

creating musical tunes using the Magicbit Tiny board. 

o Here to play a simple tune using the in-built buzzer. By providing a list of 

musical notes and their corresponding frequencies, we can create delightful 

melodies. 

o Let’s dive into the simple documentation and exploration of melodies. 

 

https://youtu.be/emDmRRFRifw


 

 How it works 

 

1. Musical Notes: 

- We have defined musical notes from C4 to D8, along with their frequencies. 

- Each note is represented by its frequency in Hertz. 

2. Melody Array: 

- We’ve created a melody array containing notes and their durations. 

- The code plays each note in sequence to produce a melody. 

3. Buzzer Output: 

- The in-built buzzer in the Magicbit Tiny board is used to generate sound. 

- The `tone()` function plays each note, and `noTone()` stops the sound. 

 

 

 Steps for the Program 

 

 

Define musical notes and corresponding frequencies 
 

 

 



 

Define the component pins 

 

 

Define the melody using above defined notes 
 
 

 

Define the setup 

 

 

 

 



 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project dimmer 

magic. 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. Then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste above Arduino code to your new sketch 

and upload the code 

 

Learning Points: 

o Array Usage: Understanding how arrays can be used to store 

musical notes and durations. 

o Buzzer Control: Learn how to generate different tones using the in-

built buzzer. 

o Musical Notes: Introduction to the concept of musical notes 

and frequencies. 

Modify the melody array to create your own tunes. Try adding or 

removing notes to see how it changes the melody. It’s your chance to 

become a musical magician! 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/7TaCVeZBFQc 

 

https://drive.google.com/file/d/17f9s_fi3UE9q7iow4DSzDh1PMmEP4rOy/view?usp=sharing
https://youtu.be/7TaCVeZBFQc


 

 
ACTIVITY 04 

04. Night Light 
 

Create a program to activate the LEDs according to the background light 

level detected by the LDR in the Magicbit Tiny. 

 

 Expected Output 

 

o https://youtu.be/g1bGuv1lukQ 

 

 Description 

 

o Welcome to the enchanting world of the Magicbit Tiny Night Light project! 

Get ready to explore how the Magicbit Tiny board can create a magical 

night light using its in-built Light-Dependent Resistor - LDR (Resistor that 

responds to the ambient light levels ). As the surroundings get darker, the 

night light activates, illuminating the LEDs. 

 

o Let’s dive into simple documentation and uncover the secrets of this 

charming project. 

 

 Use components in Magicbit Tiny: 

 

1. In-built Light-Dependent Resistor (LDR) - A7 (Analog pin 7 ) 

2. 4 LEDs - Digital pins 4, 5, 10, 11 
 

 

https://youtu.be/g1bGuv1lukQ


 

 How it works 

 

1. LDR Sensing: 

The Magicbit Tiny board is equipped with a Light-Dependent Resistor (LDR) 

that detects changes in ambient light. 

2. LED Illumination: 

We’ve connected four LEDs to different pins (4, 5, 10, 11) on the Magicbit 

Tiny board. 

When the LDR senses low light (darkness), all four LEDs illuminate. 

3. Control Logic: 

If the LDR value falls below a certain threshold, indicating darkness, all LEDs 

turn on. 

If there’s enough ambient light, the LEDs turn off. 

 

Steps for the Program 

 

 

Define the components pins 
 

 

 

Set up the pin modes 
 

 

 

 



 

Define the process 

 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project night light. 

 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste the above Arduino code to your new sketch 

and upload the code. 

Usage: 

o Place your Magicbit Tiny in a dark environment, and witness the magic 

as the LEDs light up, creating a delightful night light effect.

 

 

https://drive.google.com/drive/folders/1DiekHSy-K9xcIPKYgobl8G83ocPVqFo1?usp=sharing


 

 

Learning Points: 

o LDR Sensing: Understanding how Light-Dependent Resistors work to 

detect changes in light levels. 

o LED Control: Learning how to control LEDs based on sensor input. 

o Ambient Light: Exploring the concept of ambient light and its impact 

on the LDR. 

Experiment with the LDR sensitivity by adjusting the threshold value. See 

how the LEDs respond to different lighting conditions in your room. 

Now, let the Magicbit Tiny Night Light guide you through the night with its 

captivating glow! 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/W00Tfj9VBRs 

https://youtu.be/W00Tfj9VBRs


 

 
ACTIVITY 05 

05. Anti-Theft 
 

Create an object security alert system using the Magicbit Tiny board 
 

 

 Expected Output 

 

o https://youtu.be/NEFo_9V7h3s 

 

 Description 

 

o Welcome to the exciting world of the Magicbit Tiny Anti-Theft project! 

o Let’s explore how the Magicbit Tiny board, equipped with two in-built 

Infrared (IR) sensors and a buzzer, creates a simple yet effective anti-theft 

mechanism. 

o Get ready to understand the magic behind this fascinating project. 

o The Magicbit Tiny Anti-Theft project acts as a reliable alarm mechanism, 

notifying you when an unauthorized person attempts to take an object 

placed on the Tiny IR sensors. The integration of infrared sensors and a 

buzzer allows for quick and easy deployment of a security solution. 

 

 

 Use components in Magicbit Tiny: 

 

1. In-built Infrared (IR) Sensors - A5 and A6 (Analog Pins) 
 

 

https://youtu.be/NEFo_9V7h3s


 

2. Buzzer - Digital pin 13 

 

 

 How it works 

 

1. IR Sensing: 

- The Magicbit Tiny board is equipped with two in-built Infrared (IR) sensors 

(Left and Right). 

- These sensors detect the presence of an object placed in front of them. 

2. Alarm Activation: 

- If both IR sensors detect an object (sensor values above a threshold), the 

alarm is activated. 

3. Buzzer Control: 

- The buzzer generates a distinct sound pattern, creating an audible alert 

when the alarm is activated. 

 

Steps for the Program 

 

 

Define the components pins and threshold value 
 
 

 

 



 

Make the process 
 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project anti-theft. 

 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. Then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste above Arduino code to your new sketch 

and upload the code. 

Place the object on the designated area covering both IR sensors to activate the 

security system. 

 

 

https://drive.google.com/file/d/1evNZ6N7T5CTkddLgDcHcEkNTw8xbrlSL/view?usp=sharing


 

Learning Points: 

o IR Sensing: Understanding how Infrared (IR) sensors detect the 

presence of an object. 

o Alarm Activation: Learning the logic behind activating the alarm based 

on sensor readings. 

o Buzzer Control: Exploring how to generate distinct sound patterns 

using a buzzer. 

 

Now, let the Magicbit Tiny Anti-Theft project guard your belongings with 

its magical security features! 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

 

Tutorial in Sinhala - https://youtu.be/LBKRhoHLkDQ 

https://youtu.be/LBKRhoHLkDQ


 

 
ACTIVITY 06 

06. Tiny Buttons 
 

Create a program to control the LEDs using the push buttons in the Magicbit 

Tiny. 

 

 Expected Output 

 

o https://youtu.be/r8PI2EycvD0 

 

 Description 

 

o Welcome to the captivating world of the Magicbit Tiny Push Button LED 

Control project! Let’s embark on an exciting journey to learn how to control 

LEDs using the Magicbit Tiny board. This project introduces the concept 

of push buttons and demonstrates how pressing different buttons can 

illuminate specific sets of LEDs. 

o By pressing the left button, the left set of LEDs lights up, and by pressing the 

right button, the right set of LEDs illuminates. 

 Use components in Magicbit Tiny: 

 

1. Left Push Button - Digital Pin 12 

2. Right Push Button - Digital Pin 9 

3. Left LEDs - Digital Pin 4 and 5) 

4. Right LEDs - Digital Pin 10 and 11 
 

 

https://youtu.be/r8PI2EycvD0


 

 How it works 

 

1. Push Button Sensing: 

o We have two push buttons connected to the Magicbit Tiny board (left 

button on pin 12 and right button on pin 9). 

o The buttons are configured as inputs with pull-up resistors (pull-up 

configuration) 

Pull-up Configuration 

 

With a pull-up resistor, the input pin will read a high state when the button is not 

pressed. In other words, a small amount of current is flowing between VCC and 

the input pin (not to ground), thus the input pin reads close to VCC. When the 

button is pressed, it connects the input pin directly to ground. The current flows 

through the resistor to ground, thus the input pin reads a low state. 

 

2. LED Illumination: 

o Four LEDs are connected to different pins (left LEDs on pins 4, 5, and right 

LEDs on pins 10, 11). 

o Pressing the left button activates the left LEDs, and pressing the right 

button activates the right LEDs. 

3. Control Logic: 

o When the left button is pressed, the left LEDs light up, and the right LEDs 

turn off. 

o When the right button is pressed, the right LEDs light up, and the left LEDs 

turn off. 



 

 Steps for the Program 

 

 

Define the components pins 

 

 

 

Set up the pin modes 
 

 

 

Define the functions for LEFT and RIGHT LEDs blinking 
 

 

 

 

 



 

Call the functions in a loop 
 

 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project anti-theft. 

 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. Then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste above Arduino code to your new sketch 

and upload the code. 

Learning Points: 

o Press the left button to see the left LEDs light up or press the right 

button to witness the right LEDs illuminate. When the left button is 

pressed, the left LEDs light up, and the right LEDs turn off. When the 

right button is pressed, the right LEDs light up, and the left LEDs turn 

off. 

 

 

https://drive.google.com/file/d/1GmU4vbTU0XGLFNhKkl7DoOKWSmwaSgJP/view?usp=sharing


 

Learning Points: 

o Push Button Sensing: Understanding how push buttons can be used 

as inputs. 

o LED Control: Learning how to control LEDs based on button input 

Try to switch between different LED patterns using the push buttons. 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

 

Tutorial in Sinhala - https://youtu.be/xa3JW2JLj2E 

https://youtu.be/xa3JW2JLj2E


 

 
 

07. Door Sensor 
 

Create a program to make a DIY door sensor using Magicbit Tiny. 
 

 

 Expected Output 

 

o https://youtu.be/GzuNpUskyDY 

 

 Description 

 

o Welcome to the magical world of the Magicbit Tiny Door Sensor project! 

Let’s explore the wonders of creating a door sensor using the Magicbit Tiny 

board. This project introduces the concept of infrared (IR) sensors and a 

buzzer, allowing you to build a simple and fun door sensor. It enables us to 

create a sensor that responds when a door is opened or closed. By using 

two infrared sensors and a buzzer, we can detect the door’s movement and 

trigger a sound effect. 

 Use components in Magicbit Tiny: 

 

1. IR Sensor 1 - Pin A5 (Analog pin 5) 

2. IR Sensor 2 - Pin A6 (Analog pin 6) 

3. Buzzer - Digital Pin 13 

https://youtu.be/GzuNpUskyDY


 

 How it works 

 

1. IR Sensor Sensing: 

o Two IR sensors are connected to the Magicbit Tiny board (IR sensor 1 

on pin A5 and IR sensor 2 on pin A6). 

o The sensors read analog values based on the presence of an object 

(e.g., a door) in their vicinity. 

 

2. Buzzer Activation: 

o If the IR values from both sensors are less than 400, it indicates that 

the door is present (closed). 

o The buzzer is triggered to produce a tone, creating a doorbell-like 

effect. 

o After a short delay, the buzzer turns off. 

 

 

 Steps for the Program 

 

 

Define the components pins 

 

Configure the pins 

 

 

 



 

Make the process as a loop 

 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project anti-theft. 

 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. Then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste above Arduino code to your new sketch 

and upload the code. 

Usage: 

o Create a door / home structure using a piece of cardboard. 

o Place the Magicbit Tiny which the above code uploaded near the door 

as shown in the figure below. 

o Power the Magicbit Tiny using battery power. 

o When the door is opened, the buzzer will produce a sound. 

o Experiment by opening and closing the door to trigger the doorbell-like 

effect. 

 

https://drive.google.com/file/d/1A5QuqNt4wu6DRp7kxveJzYsBTcUGUVkA/view?usp=sharing


 

 

 

 

Learning Points: 

o IR Sensor Sensing: Understanding how infrared sensors detect the 

presence of objects. 

o Buzzer Activation: Learning how to use a buzzer to create sound 

effects based on sensor input. 

 

Try adjusting the IR sensor sensitivity by modifying the threshold value. 

Experiment with different tones or melodies for the buzzer. 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

 

Tutorial in Sinhala - https://youtu.be/gm2MCABAlBg 

https://youtu.be/gm2MCABAlBg


 

 
ACTIVITY 08 

08. DIY Sensor 
 

Create a program to indicate the conductivity of different materials as a 

Neo-pixel indicator using the Magicbit Tiny. 

 

 Description 

 

o The project features a visual indicator using a single Neo-Pixel RGB LED, 

providing real-time feedback based on the conductivity value. The Neo-Pixel 

LED changes its color to represent different conductivity levels as well as 

moisture levels 

o In this project we use Magicbit tiny in built pull up resistor. 

o A pull-up resistor is used in electronic circuits to ensure a stable voltage 

level, typically high (1), when no other active device is driving the line low 

(0). It connects a signal line to the positive voltage supply, preventing it from 

floating or picking up stray signals. Pull-up resistors are essential for reliable 

input readings in microcontroller-based systems, ensuring defined logic 

levels. In tiny, the pull up resistor has been connected to pin 8. 

 

 Use components in Magicbit Tiny: 

 

1. Tiny in built pull up resistor - Digital pin 8 (D8) 

2. RGB LED – pin 0 

3. 2 M-M jumper wires 
 

 



 

Special Note: 

pin 8 can be act as a digital pin as well as an analog pin. 

 

o Connect the two M-M jumper wires to the pin 8 and GND pins in the Magicbit 

Tiny as follows. 

 

 How it works 

 

1. Read Conductivity / moisture level:  

The analog value from pin 8 is read, representing the conductivity of the 

sensor circuit. 

2. Convert to Voltage: 

The analog value is converted into a voltage to interpret the conductivity 

level accurately. 

3. Color Coding: 

The Neo-Pixel RGB LED changes its color based on predefined 

conductivity and moisture ranges. 
 

 



 

4. Display Update: 

The Neo-Pixel displays the relevant color. 

 

 Steps for the Program 

 

 

Include the required libraries and define the pins 

 

 

Make the setup 

 

 

Make the loop 

 

 

 

 



 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project anti-theft. 

 

1. Connect Magicbit Tiny using the USB cable to a computer. 

2. Open the Arduino IDE and get a New Sketch from the File menu. 

3. Then in the Tool tab, select Board -> Magicbit Tiny -> MagicBit Tiny 

4. In the same Tool tab select port -> COM<your port number> 

5. Type or copy and paste the above Arduino code to your new sketch 

and upload the code. 

6. Click on the icon on the top right corner of the Arduino IDE to open the 

Serial Monitor to view the conductivity value and corresponding color. 

 

 

Observe the color changes on the Neo-Pixel LED based on the 

conductivity level. 

Neo pixel RGB color for different conductivity level as follows. 

 

https://drive.google.com/file/d/19ELGxqX0sbvFV9mtGW6_djqI28UavOvc/view?usp=sharing


 

Customization: 

o Adjust the threshold voltage values in the code to customize 

conductivity levels and colors. 

o  Experiment with different Neo-Pixel patterns or multiple LEDs for 

enhanced visual feedback. 

 

Learning Points: 

o Understanding the relationship between conductivity and color. 

o Hands-on experience with a simple conductivity sensor circuit. 

o Introduction to interpreting analog sensor values. 



 

 
ACTIVITY 09 

09. Rainbow Light Magic 
 

Create a program to witness a magical rainbow light pattern using the Neo- 

Pixel LED embedded in the Magicbit Tiny board. 

 
 Expected Output 

 

o https://youtu.be/akGnjOL4qwg 

 

 

 Description 

 

o The project features how the Magicbit Tiny board can create a mesmerizing 

rainbow light effect using its built-in Neo-Pixel LED. Let’s dive into the simple 

documentation and uncover the secrets of this colorful project. 

 Components 

 

1. Magicbit Tiny Board 

2. Built-in Neo-Pixel LED 

 

 How it works: 

 

1. Neo-Pixel LED: 

The Magicbit Tiny board features a built-in Neo-Pixel LED that can display a 

spectrum of colors. 

2. Color Pattern: 

The project displays a captivating pattern of colors sequentially, creating a 

magical rainbow effect. 

https://youtu.be/akGnjOL4qwg


 

 Steps for the Program 

 

 

Include the required libraries and define the pins 

 

 

Make the setup 

 

 

Make the loop 
 

 

 

 

 



 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for project anti-theft. 

 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Goto file -> New Sketch and copy and paste the above Arduino 

code to your new sketch and upload the code. 

Observe the mesmerizing rainbow light pattern as it unfolds 

automatically. 

Learning Points: 

o Neo-Pixel LED: Understanding the built-in programmable LED on the 

Magicbit Tiny board. 

o Color Patterns: Exploring the creation of dynamic color patterns. 

 

Experiment: 

o Adjust the speed of the color pattern by changing the parameter in the 

`colorPattern` function. 

o Now, let the Magicbit Tiny Rainbow Light Magic project fill your 

surroundings with vibrant colors and magic! 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/wdR_UOQrHts 

https://drive.google.com/file/d/1E69SQL0J6oJF-vw3N4rVQfvaDXJENaho/view?usp=sharing
https://youtu.be/wdR_UOQrHts


 

 
 

10. People Count 
 

Create a program to count the people using the Proximity IR sensors 

embedded in the Magicbit Tiny board. 

 
 Expected Output 

 

o https://youtu.be/c93mD88_Z3g 

 

 

 Description 

 

o The People Counting project is a simple yet effective application of infrared 

(IR) sensors with the Magicbit Tiny Board. Using two IR sensors, this project 

accurately counts the number of people entering and exiting a defined area. 

The system increments the count when someone enters and decrements the 

count when someone exits, providing real-time people counting capabilities. 
 

 Components 

 

1. Magicbit Tiny Board 

2. Infrared (IR) Sensor 1 (A5) 

3. Infrared (IR) Sensor 2 (A6) 

 

 How it works: 

 

1. IR Sensor Sensing: 

- IR Sensor 1 (A5) detects individuals entering. 

- IR Sensor 2 (A6) detects individuals exiting. 

https://youtu.be/c93mD88_Z3g


 

2. IR Sensor Sensing: 

- When IR Sensor 1 reads a value below 700, the people count increments, 

indicating an entry. 

- When IR Sensor 2 reads a value below 700, the people count decrements, 

indicating an exit. 

 Steps for the Program 

Define the components pins 
 

 

Make the setup / serial monitor 
 

Arrange the loop 
 

 

 

 



 

Full Program 

Download the program code from here 

 

Follow below steps to upload example code for project anti-theft. 

 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Goto file -> New Sketch and copy and paste above Arduino code to 

your new sketch and upload the code. 

 

Place the Magicbit Tiny People Count system at an entrance and witness 

the count increase with entries and decrease with exits. 

 

Learning Points: 

o IR Sensor Operation: 

Understand how IR sensors detect individuals passing through. 

o Logical Counting: 

Learn the basics of counting logic based on sensor readings. 

 

Adjust the threshold value (700) and observe how it affects the sensitivity 

of the people count system. 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/bFmAKzFzATA 

https://drive.google.com/file/d/165EoRS0fb2wwjweBZKkJ0gyoeGmuYh3b/view?usp=sharing
https://drive.google.com/file/d/165EoRS0fb2wwjweBZKkJ0gyoeGmuYh3b/view?usp=sharing
https://youtu.be/bFmAKzFzATA


 

 
ACTIVITY 11 

11. Motor Controlling 
 

Create a program to control the speed and direction of two motors using a 

potentiometer. 

 
 Expected Output 

 

o https://youtu.be/22XTVQAdaRY 

 

 

 Description 

 

o This project introduces you to the basics of motor control using the built-in 

motor driver L9110S on the Magicbit Tiny board. Let’s dive into the simple 

documentation and explore the wonders of this engaging project. 

 Components 

 

1. Magicbit Tiny Board 

2. Built-in Motor Driver L9110S (2x) 

3. Built-in Potentiometer 

4. 3.7 V battery 

5. DC Motors (2x) 

 

 How it works: 

 

1. Potentiometer Input: 

o The potentiometer (connected to analog pin A3) reads user input. 

o Potentiometer values are mapped to a range of motor speeds (-255 to 

255). 

2. Motor Control: 

o The built-in motor driver L9110S simplifies motor control. 

o Motor 1 and Motor 2 speed and direction are adjusted based on the 

potentiometer input. 

https://youtu.be/22XTVQAdaRY


 

3. Potentiometer Input: 

o The project provides optional serial monitor output, displaying 

potentiometer values and motor speeds for further exploration. 

 

 Steps for the Program 

 

 

Define the pins and variables 

 

 

Make the setup 
 
 

 

Make the loop 
 

 

 

 



 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for tiny motor controlling 

project 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 

o After uploading the code, remove the USB connector. 

o Connect the extension module to the Magicbit Tiny. 

o Connect a 3.7V battery to the battery connector on the Extension. 

o Connect the motors to the motor connectors in the extension and turn 

on the switch. 

o Experiment with different potentiometer values and observe how 

motor behavior changes. Try adjusting the delay duration for a 

different responsiveness. 

 

 

 

https://drive.google.com/file/d/1t7Nj5kIt6Dq02_9y3wffX8W-CxzfnnuQ/view?usp=sharing


 

Learning Points: 

o Introduction to Motor Drivers: Understanding the role of the built-in 

L9110S motor driver. 

o Potentiometer Interaction: Learning how to use a potentiometer for 

input. 

o Motor Speed Control: Exploring how to control motor speed based on 

user input. 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/fU8y88mVCzw 

https://youtu.be/fU8y88mVCzw


 

 
 

12. Obstacle Avoiding Car 
 

To build a robot car that can navigate while avoiding obstacles. 

 
 Expected Output 

 

o https://youtu.be/LPN8Rmhk8iM 

 

 Description 

 

o This project introduces you to the exciting combination of an ultrasonic 

sensor and motor control on the Magicbit Tiny board. It enables you to build 

a robot that can navigate and avoid obstacles using an ultrasonic sensor. 

This project leverages motor control to enable the robot to move forward 

and turn right based on the sensor readings. 

 

 How it works: 

 

1. Ultrasonic Sensor: 

o The HC-SR04 ultrasonic sensor is used to measure the distance to 

obstacles. 

2. Motor Control: 

o DC motors are controlled using the built-in motor driver L9110S. 

o Motor functions include moving forward, backward, stopping, and turning 

right. 

3. Obstacle Avoidance: 

o If an obstacle is detected within a certain range (e.g., 10 cm), the robot 

turns right to avoid it. 

4. Serial Monitor (Optional): 

o Distance readings are displayed on the Serial Monitor for monitoring and 

debugging.

https://youtu.be/LPN8Rmhk8iM


 

 Set-Up: 

 

o Build the robot car structure according to the steps given in the below video. 

Robot Assembling Guide - https://youtu.be/q6y0NJX4XmA 
 

 

 

 Steps for the Program 

 

 

Define the libraries 

 

 

This library (used for ultrasonic sensor with Magicbit Tiny) is a custom 

made library . 

Download the Ultrasonic Library Here 

 

Install the “Ultrasonic.h’’ library to your Arduino interface before you 

run the below program. 

 

https://youtu.be/q6y0NJX4XmA
https://drive.google.com/drive/folders/1pEzSdpqTR9CXjt8_QGXOzpI18P7TYlxE?usp=drive_link


 

Define the pins and variables 

 

 

 

Make the setup 
 

 

 

 

 

Make the loop 
 

 

 

 

 



 

Make the functions for forward and right or left motions 
 

 

 

Full Program 

Download the program code from here 

 

Follow below steps to upload example code for obstacle avoiding robot 

car project. 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Goto file -> New Sketch and copy and paste above Arduino code to 

your new sketch and upload the code. 

Learning Points: 

o Ultrasonic Sensor Usage: Understanding how the HC-SR04 

measures distance. 

o Motor Control Logic: Learning how to control DC motors for various 

movements. 

o Obstacle Avoidance: Exploring the concept of using sensors to avoid 

obstacles. 

 

https://drive.google.com/file/d/1ACXjBPUS4F3N3UArJjQnuiiSwE8-q9Yj/view?usp=sharing


 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/1mzosiE-jWc 

https://youtu.be/1mzosiE-jWc


 

 
 

13. Line Follower Car 
 

To build a robot car that can navigate while following a line / track. 

 
 Expected Output 

 

o https://youtu.be/nZds7kcdqco 

 

 Description 

 

o The Magicbit Tiny Line Following Robot project allows you to create a robot 

that can follow a line using infrared sensors. By adjusting motor speeds 

based on sensor readings, the robot can navigate along a predefined path. 

 

 How it works: 

 

1. Infrared Sensors: 

o Two built-in IR sensors are used to detect the line beneath the robot. 

2. Motor Control: 

o DC motors are controlled using the built-in motor driver L9110S. 

o Motor speeds are adjusted based on the readings from the IR sensors. 

3. Line Following Logic: 

o The robot adjusts its movement to stay on the line, using the difference in 

sensor reading. 

4. Serial Monitor (Optional): 

o Sensor values and motor speeds are displayed on the Serial Monitor for 

monitoring and debugging. 

https://youtu.be/nZds7kcdqco


 

 

 

 Set-Up: 

 

o Build the robot car structure according to the steps given in the below video. 

(It is the same robot car you used in Obstacle Avoiding Car Activity) 

Robot Assembling Guide - https://youtu.be/q6y0NJX4XmA 

 

 

 Steps for the Program 

 

 

Define the component pins 
 

 

Make the setup 
 

 

 

https://youtu.be/q6y0NJX4XmA


 

Make the loop 
 

 

Full Program 

Download the program code from here 

 

Follow below steps to upload example code for obstacle avoiding robot 

car project. 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 

Prepare a line following track (Black line in a white surface or White line in 

a Black surface / Line width [2cm -3 cm]). 

Download printable Line Follower Track 

 

https://drive.google.com/file/d/1I9Vpe0rzAEaFkqxqyyBo6ujZluVvTw_K/view?usp=sharing
https://drive.google.com/file/d/1I9Vpe0rzAEaFkqxqyyBo6ujZluVvTw_K/view?usp=sharing
https://drive.google.com/file/d/1yxoFkhBaeNoNTSKU1nsgiqaIjrb9AfOw/view?usp=sharing
https://drive.google.com/file/d/1yxoFkhBaeNoNTSKU1nsgiqaIjrb9AfOw/view?usp=sharing


 

 

 

 

Important - This document is scaled to A2 size. 

 

Learning Points: 

o IR Sensor Usage: Understanding how IR sensors detect variations in 

reflectivity. 

o Motor Control for Line Following: Learning how to control DC motors 

to navigate along a line. 

o Logic for Line Following: Exploring the concept of adjusting motor 

speeds based on sensor readings. 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/2zW-tE3mnxI 

https://youtu.be/2zW-tE3mnxI


 

 
 

14. Robot Roach 
 

To build a robot car that is sensitive to light intensity. 

 
 Expected Output 

 

o https://youtu.be/hP4Kq4Hnfe0 

 

 Description 

 

o This project introduces you to the exciting combination of an LDR sensor 

and motor control on the Magicbit Tiny board. It enables you to build a robot 

that mimics the behavior of a cockroach by moving away from light sources 

detected by the LDR. This project leverages motor control to enable the 

robot to steer and move accordingly based on the light intensity readings. 

 

 How it works: 

 

1. Infrared Sensors: 

o Two built-in IR sensors are used to detect the line beneath the robot. 

2. Motor Control: 

o DC motors are controlled using the built-in motor driver L9110S. 

o Motor speeds are adjusted based on the readings from the IR sensors. 

3. Line Following Logic: 

o The robot adjusts its movement to stay on the line, using the difference in 

sensor reading. 

4. Serial Monitor (Optional): 

o Sensor values and motor speeds are displayed on the Serial Monitor for 

monitoring and debugging. 

https://youtu.be/hP4Kq4Hnfe0


 

 

 

 Set-Up: 

 

o Build the robot car structure according to the steps given in the below video. 

(It is the same robot car you used in Obstacle Avoiding Car Activity) 

Robot Assembling Guide - https://youtu.be/q6y0NJX4XmA 

 

 

 Steps for the Program 

 

 

Define the component pins 
 

Make the setup 

 

 

 

https://youtu.be/q6y0NJX4XmA


 

Make the loop 
 

 

 

 

 



 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for Roach Robot project. 

 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 

o Open the Serial Monitor in Arduino IDE and see how the light level 

readings vary according to the light level in your background. 

o Adjust the threshold value in the code according to that. 

o Upload the final code and remove the USB cable while powering via 

batteries. 

Direct a torch light or flashlight to increase the light intensity and observe 

how robot avoid the lights. 

https://drive.google.com/file/d/1LhNdGDlWFRKRCWAbk-rZVxxdjvcBEjhk/view?usp=sharing


 

 
 

15. Dancing Robot 
 

To build a robot car that behaves like dancing to music. 

 
 Expected Output 

 

o https://youtu.be/1p1UN6Dc_14 

 Description 

 

o This project introduces you to the exciting combination of motor control, a 

buzzer, and Neo-pixel LEDs on the Magicbit Tiny board. It enables you to 

build a robot that mimics a dancing robot by performing various movements, 

generating musical tones through the buzzer, and displaying vibrant color 

patterns using the Neo-pixel LEDs. This project leverages motor control to 

choreograph the robot’s movements, synchronized with dynamic audio and 

visual effects to create an engaging and interactive experience. 

 How it works: 

 

1. Neo-pixel LEDs 

o The Neo-pixel LEDs are used to create dynamic lighting effects, displaying 

a variety of colors and patterns to enhance the dancing experience. 

o The colors and patterns are synchronized with the robot’s movements 

and the musical tones. 

2. Motor Control: 

o  DC motors are controlled using the built-in motor driver on the Magicbit 

Tiny board. 

o Motor functions include performing different movements like spinning, 

swaying, or stepping in sync with the music and lighting effects. 

https://youtu.be/1p1UN6Dc_14


 

1. Neo-pixel LEDs 

o The Neo-pixel LEDs are used to create dynamic lighting effects, displaying 

a variety of colors and patterns to enhance the dancing experience. 

o The colors and patterns are synchronized with the robot’s movements 

and the musical tones. 

2. Motor Control: 

o DC motors are controlled using the built-in motor driver on the Magicbit 

Tiny board. 

o Motor functions include performing different movements like spinning, 

swaying, or stepping in sync with the music and lighting effects. 

3. Musical Tones: 

o The onboard buzzer generates musical tones to accompany the robot’s 

movements. 

o The tones can be customized to create rhythmic or melodic sequences 

for a more engaging performance. 

 

 Set-Up: 

 

o Build the robot car structure according to the steps given in the below video. 

(It is the same robot car you used in Obstacle Avoiding Car Activity) 

Robot Assembling Guide - https://youtu.be/q6y0NJX4XmA 
 

 
 
 

 

https://youtu.be/q6y0NJX4XmA


 

 Steps for the Program 

 

 

Add the required Libraries 

 

 

Define the component pins 

 

 

Make the setup 
 

 

 

 

 



 

Create the other functions 
 

 

 

 



 

 
 

 



 

 

Full Program 

Download the program code from here 

 

Follow the steps below to upload example code for Roach Robot project. 

 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Goto file -> New Sketch and copy and paste the above Arduino 

code to your new sketch and upload the code. 

 

In the above program, you can change the colors according to their relevant 

RGB values. 

https://drive.google.com/drive/folders/1l8MdIXPuo5-xQxWAe-DbUSGPHIcO6IVM?usp=sharing


 

 

 

 

In the above program, you can change the playing tones by changing the 

relevant frequencies for different notes. 

 

Refer the code in Activity 03 – Melody Magic for different nots and their 

respective frequencies. 



 

 
 

16. Path Clearing Robot 
 

To build a robot car that can navigate while clearing his path. 

 
 Expected Output 

 

o https://youtu.be/31B12WFps18

 Description 

o The Magicbit Tiny Path Clearing Robot project enables you to build a robot 

that can navigate and detect obstacles in his path using an ultrasonic 

sensor. And then by operating the servo motor it can grab the detected 

object and remove it from his path and continue robot’s motion. This project 

leverages motor control to enable the robot to move forward and turn Right / 

Left based on the sensor readings and operate the servo motor. 

 

 

 How it works: 

 

1. Ultrasonic Sensor: 

o The HC-SR04 ultrasonic sensor is used to measure the distance to 

obstacles. 

2. Motor Control: 

o DC motors are controlled using the built-in motor driver L9110S. 

o Motor functions include moving forward, backward, stopping, and turning 

right / left. 

3. Grabbing the objects: 

o If an obstacle is detected within a certain range (e.g., 10 cm), the robot 

operates its arm by operating the servo motor to grab the object and 

remove it from the moving path. 

https://youtu.be/31B12WFps18
https://youtu.be/31B12WFps18


 

4. Serial Monitor (Optional): 

o The Distance readings are displayed on the Serial Monitor for monitoring 

and debugging. 

 

 Set-Up: 

 

o Use the same robot used for Obstacle avoiding and line following robot with 

below modifications. 

 

Robot Assembling Guide - https://youtu.be/hq_ozjGHdt8 
 

 

 

 Steps for the Program 

 

 

Add the required Libraries 
 

 

Define the component pins 

 

 

 

https://youtu.be/hq_ozjGHdt8


 

Make the setup 
 

 

 

Make the loop 
 
 

 

 

 

 

 



 

 

Create the other functions 
 

 

 



 

Follow the steps below to upload example code for path clearing robot 

car project. 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

Important - Install the “Ultrasonic.h’’ library to your Arduino 

interface before you run the below program. 

 

The library used for ultrasonic sensor with Magicbit Tiny is a custom 

made library. 

 

Download the Ultrasonic Library Here 

 

 

Observe how the robot navigates its environment, avoiding obstacles 

based on the ultrasonic sensor readings. 

 

No need of installing “TinyServo.h’’ library manually as it is already 

installed with Magicbit Tiny Board. 

Full Program 

Download the program code from here 

https://drive.google.com/drive/folders/1pEzSdpqTR9CXjt8_QGXOzpI18P7TYlxE?usp=drive_link
https://drive.google.com/drive/folders/1qdIFfxhOpgnQ76AICSLVozDPn159T5cl?usp=sharing


 

 
 

17. Automatic Rail Gate 
 

To create a program to operate the wooden arm connected servo motor as a 

rail gate according to the detection of the train. 

 Description 

o This project introduces you to the exciting combination of Proximity IR 

sensor and servo motor control on the Magicbit Tiny board. It enables you to 

build a setup that mimics the behavior of a rail gate which block the road 

when a train is to cross the road and once the train passes the road, the gate 

get open back allowing the vehicles to cross the rail way. 

 

 Components 

 

o Magicbit Tiny Board 

o Tiny extension module 

o USB cable 

o M-M jumper wires 

o Cardboard 

o Servo motor 

o Printed Track 

o Wooden servo arm 

 

 

 How it works: 

 

1. Proximity IR Sensor 

o IR sensors detect the presence of an object (train). 



 

2. Servo Motor: 

o The servo motor regulates the gate’s opening and closing mechanism. 

o Upon detecting the train, the servo motor rotates to the given position 

(angle) making the gate close. 

o After a given time period, it rotates back to another given position making 

the gate opened. 

o Time period is decided according to the time taken by the train to pass 

the gate 

 Set-Up: 

Take a printout of the below track - Print the Track  

 

o Paste the printed track on piece of cardboard and remove the area marked 

as “Tiny” 

 

o Place Magicbit tiny as below. 

https://1drv.ms/b/c/b8bf73396625e6bd/EaCOYd73C15AgWbFZyewKssBgAwermsGjrsuDdGfksuIEg?e=WQ4s8b


 

 

o Fix the wooden servo arm with the servo motor. 
 

 

o Attach the servo motor in the marked area of the set up at a higher level . 

o Connect the servo motor cable with tiny extension at pin 8 

 

 

 
 

o Connect the extension with Magicbit Tiny and power the whole set up via 

batteries by connecting the battery connector to the extension. Turn ON the 

switch in the extension. 

o Set-up creation guidelines - https://youtu.be/gxgTAXWFNac 

 
 

Get the positions of the servo motor 

 

Follow the steps below to upload example code for path clearing robot 

car project. 

https://youtu.be/gxgTAXWFNac


 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste below Arduino code 

to your new sketch and upload the code. 

 

Download the program code from here 

 

In the above code, change the value ‘’90’’ to any value in between 0 - 180 

and identify the two values corresponding to the gate opened position 

and gate closed position. 

Upload the below program to operate the servo motor according to the 

motion detected by the IR proximity sensor in the Magicbit Tiny. 

 

Download the code 

 

 

o Upload the above code and move your hand over the IR sensors and 

observe how the reading get vary due to detection of your hand. 

o Depending on that, change the threshold value in the above code 

and re-upload the code. 

o Observe how the system operates. 

https://drive.google.com/drive/folders/1FQjzKHD2XieMc-zusqOu2Syt4HNaRHVU?usp=sharing
https://drive.google.com/drive/folders/1bZll4hX2NocKv1ThimHQ1woGmxrx-_cV?usp=sharing


 

 
 

18. Fire Detector 
 

To create a program to detect fire using proximity IR sensors and 

indicate the detection via the Neo-pixel LED and the buzzer. 

 
 Expected Output 

 

o https://youtu.be/SCdrDc_XSSc 

 

 Description 

 

o The Magicbit Tiny Fire Detector project enables the creation of a sensor that 

responds to the presence of fire. By utilizing two infrared sensors, a buzzer, 

and an RGB LED, this project offers a visual and audible alarm system based 

on the severity of the detected fire. 

 Components 

 

o IR Sensor 1 (Pin: A5) 

o IR Sensor 2 (Pin: A6) 

o Buzzer (Pin: 13) 

o RGB LED (1 Neo-pixel, Pin: 0) 

 

 

 How it works: 

 

1. Proximity IR Sensor 

o Two IR sensors are connected to the Magicbit Tiny board (IR sensor 1 on 

pin A5 and IR sensor 2 on pin A6). 

o The sensors read analog values based on the intensity of infrared 

radiation emitted by the fire. 

https://youtu.be/SCdrDc_XSSc


 

2. Proximity IR Sensor 

o The RGB LED (Neo-pixel) provides visual feedback. 

o The LED changes color based on predefined fire severity levels: 

o Green for no fire 

o Yellow for a small fire 

o Red for a considerably large fire 

o If either IR sensor detects a fire, the RGB LED changes color accordingly. 

3. Buzzer Activation 

o The buzzer is triggered to produce different tones based on the fire 

severity. 

 

 

 

 Steps for the Program 

 

 

Define the libraries, pins and variables 

 

 

Make the set up 
 

 

 



 

Make the loop 

 

 

 

Full Program 

Download the program code from here 

Follow below steps to upload example code. 

 

https://drive.google.com/file/d/1Gf9KrfhzwU1mRd5RS_0Ho-xVZ9FZljji/view?usp=sharing


 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 Set-Up: 

 

o Fix the Magicbit Tiny into the wooden stand as follows. 

o Use a candle or a lighter as the fire 
 

 

 

Learning Points: 

• IR Sensor Sensing: Understanding how infrared sensors detect fire 

based on emitted radiation. 

• Visual and Audible Indication: Implementing an RGB LED and buzzer 

for effective feedback. 

• Experimentation: Customizing thresholds and tones for different fires 

severity levels. 

 

o Adjust the IR sensor sensitivity by modifying the threshold value. 

o Experience with different RGB LED colors and buzzer patterns for enhanced 

visual and audible alerts. 



 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

Tutorial in Sinhala - https://youtu.be/U7jE-M-VZIc 

https://youtu.be/U7jE-M-VZIc


 

 
 

19. DIY Color Sensor 
 

To create a program to detect the ambient light’s color using LDR and 

displays it through a Neo-Pixel RGB LED. 

 
 Expected Output 

 

o https://youtu.be/KZLFKqs3maE 

 

 Description 

 

o The Magicbit Tiny Color Sensor project uncover the magic of detecting and 

visualizing colors using the Magicbit Tiny board, an LDR (Light Dependent 

Resistor), and a Neo-Pixel RGB LED. This project introduces you to the 

wonders of color detection and provides a captivating visual display of the 

colors around you. Witness the colors of your surroundings come alive in a 

dazzling display of light. 

 How it works: 

 

1. Color Sensing with LDR: 

o The LDR is used to sense the ambient light’s intensity and color. 

o The LDR’s resistance changes based on the color of light falling on it. 

2. Neo-Pixel RGB LED Display: 

o The Neo-Pixel RGB LED visually represents the detected color. 

o Each color (Red, Green, Blue) is associated with specific conditions 

detected by the LDR. 

o The Neo-Pixel lights up in the corresponding color based on the color 

detected. 

https://youtu.be/KZLFKqs3maE


 

 Steps for the Program 

 

 

Define the libraries, pins and variables 

 

 

Make the set up 
 

 

 

Make the loop 

 

 

Full Program 

Download the program code from here 

Follow below steps to upload example code. 

 

 

 

https://drive.google.com/file/d/1KiWIoTjAt8A3nji-UJKciG3iELf-Wqsg/view?usp=sharing


 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 

o Place the Magicbit Tiny Color Sensor (LDR) in different lighting conditions 

and observe the Neo-Pixel displaying the corresponding color based on the 

ambient light. 

o Experiment with different threshold values for Red, Green, and Blue to fine- 

tune color detection. 

o Try adding more Neo-Pixels to create a colorful light display based on the 

dominant color detected. 

 

Learning Points: 

• LDR Color Sensing: Understanding how LDRs detect colors based on 

changes in resistance. 

• Visual Indication: Implementing a Neo-Pixel for an engaging and 

colorful visual display. 

• Experimentation: Adjusting LDR thresholds to customize color 

detection. 



 

 
 

20. Automatic Plant Watering System 
 

To create a program to water the plant automatically in given time intervals. 

 
 Expected Output 

 

o https://youtu.be/JVMcvTRdU14 

 Description 

 

o The Automatic Plant Watering Project using the Magicbit Tiny Board and 

a Servo Motor transforms traditional plant care by introducing an efficient, 

hands-free watering mechanism. The servo motor controls the water flow, 

providing a simple and effective solution for plant enthusiasts. 

 Components: 

1. Magicbit Tiny Board 

2. Tiny Extension board 

3. SG90 Servo Motor 

4. Wooden parts from Magicbit Tiny Kit 

5. Connecting Wires 

 

 How it works: 

 

1. Servo Motor Control: 

o The Magicbit Tiny board interfaces with a servo motor to control the 

opening and closing of the water valve. Servo motor can do the blocking 

and unblocking the water flow through the tube. 

2. Tap Opening and Closing: 

o The `openTap()` function activates the servo to open the tap, allowing 

water to flow. 

o The ̀ closeTap()` function closes the tap, stopping the water flow. 

https://youtu.be/JVMcvTRdU14


 

3. Automated Watering Cycle: 

o In the `loop()` function, the tap opens for a specified duration to water the 

plant. 

o After watering, the tap closes, and the system waits before checking the 

moisture level again. 

 Set-Up: 

 

o Make the set-up as the steps given below. 

o Set up Assembly guide - https://youtu.be/UXcOkR2513Q 
 

 

 

 

 

 Steps for the Program 

 

 

Define the libraries, pins and variables 
 

 

 

https://youtu.be/UXcOkR2513Q


 

Make the setup 
 

 

 

Make the “open” and “close” functions 

 

 

Make the loop 

 

 

 

SPECIAL NOTE: 

When you are dealing with servo motor with Magicbit tiny you have to use 

TinyServo.h library instead of Servo.h library. It will be automatically downloaded 

when to install the Magicbit Tiny board via Arduino board manager. 

 

Full Program 

Download the program code from here 

Follow below steps to upload example code. 

 

 

 

https://drive.google.com/file/d/1j1Fh4rDQoQhD5K_k9_i1fZlkxncgQp9z/view?usp=sharing


 

Follow the steps below to upload example code for path clearing robot 

car project. 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, Go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

Learning Points: 

• -Servo Motor Control: Gain insights into using a servo motor for 

precise control in automation projects. 

• Timing and Delays: Understand the importance of timing and delays 

in coordinating actions, such as opening and closing a water tap. 

• Automated Systems: Explore the concept of automation in daily 

tasks, emphasizing efficiency and convenience. 

 

Benefits and Future Enhancements: 

1. Water Efficiency: Prevent overwatering by customizing the watering 

duration. 

2. Remote Monitoring: Integrate sensors to monitor soil moisture 

remotely. 

3. Solar Power: Implement solar-powered solutions for sustainable 

plant care. 

 

If you need the same activity in Sinhala Medium, go through the below Video. 

 

Tutorial in Sinhala - https://youtu.be/woOrB6Y_ZSo 

https://youtu.be/woOrB6Y_ZSo


 

 
 

21. Automatic Water Tap 
 

To create a program to operate the tap automatically with the presence of 

hands. 

 Expected Output 

 

o https://youtu.be/aVyoYc11diQ 

 Description 

 

o The Automatic Plant Watering Project using the Magicbit Tiny Board and 

a Servo Motor transforms traditional plant care by introducing an efficient, 

hands-free watering mechanism. The servo motor controls the water flow, 

providing a simple and effective solution for plant enthusiasts. 

 Components: 

1. Magicbit Tiny Board & Extension Board 

2. Arduino Magic Kit (Automatic Water Tap Kit Setup) 

3. Servo Motor 

4. Battery 

 

 

 How it works: 

 

1. IR Sensor Detection: 

o IR sensors detect the presence of an object (such as a hand) near the tap. 

o Sensor readings indicate whether an object is within the detection range. 

2. Servo Motor Control: 

o The servo motor regulates the water tap’s opening and closing 

mechanism. 

o Upon detecting an object, the servo motor opens the tap to allow water 

flow. 

o After a set duration, the servo motor closes the tap to stop water flow. 

https://youtu.be/aVyoYc11diQ


 

 Set-Up: 

 

o Make the set-up as the steps given below. 

o Set up Assembly guide - h t t p s : / / y o u t u . b e / e G u m r u q G d o 4  

 

 Steps for the Program 

 

 

Define the libraries, pins and variables 

 

 

Make the setup 
 

 

Make the “open” and “close” functions 

 

 

 

 

https://youtu.be/eGumruqGdo4


 

Make the Loop 

 

 

Full Program 

Download the program code from here 

 

SPECIAL NOTE: 

When you are dealing with servo motor with Magicbit tiny you have to 

use TinyServo.h library instead of Servo.h library. It will be 

automatically downloaded when installing the Magicbit Tiny board via 

Arduino board manager. 

 

Follow the steps below to upload example code for Roach Robot project. 

 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 

https://drive.google.com/drive/folders/1qGAYoW92dOUjFKPDlTegxPf4zGPv-bSl?usp=sharing


 

• Experiment with different servo motor positions and delays to optimize 

water flow control. 

• Explore alternative sensor technologies for object detection, such as 

ultrasonic or capacitive sensors. 

• Customize the project by incorporating additional features, such as 

temperature sensing or water level monitoring. 

 

If you need the same activity in Sinhala Medium, go through the below 

Video. 

 

Tutorial in Sinhala – https://youtu.be/_uReyCEsHfU 

https://youtu.be/_uReyCEsHfU


 

 
 

22. DIY Radar System 
 

To create a program to create a radar system capable of detecting objects 

within a limited range. 

 Expected Output 

 

o https://youtu.be/FIk1webzWMw

 Description 

o Delve into the world of object detection and visualization with the Magicbit 

Tiny Radar Project, crafted with the Arduino Magic Kit. This exciting 

endeavor combines the power of Arduino and Processing IDE to create 

a radar system capable of detecting objects within a limited range. Let’s 

embark on this journey together and explore the magic of technology. The 

Magicbit Tiny Radar Project combines hardware and software to create a 

radar-like system capable of detecting objects within a certain range. By 

utilizing ultrasonic sensors and visualization techniques in Processing IDE, 

this project offers a glimpse into the world of object detection and tracking. 

 

 Components: 

1. Magicbit Tiny Board 

2. Ultrasonic Sensor 

3. Connecting Wires 

4. Servo Motor 

5. Arduino Magic Kit (Radar Project Kit) 

 

  Software required to install: 

 

o Processing ID – Download this file 

https://youtu.be/FIk1webzWMw
https://youtu.be/FIk1webzWMw
https://github.com/processing/processing4/releases/download/processing-1293-4.3/processing-4.3-windows-x64.zip


 

 How it works: 

 

1. Ultrasonic Sensor Integration: 

o The Magicbit Tiny board interfaces with an ultrasonic sensor to measure 

the distance between the sensor and nearby objects. 

o  By emitting ultrasonic waves and analyzing the echo, the system 

determines the distance of the detected object. 

2. Data Visualization: 

o The Processing IDE translates the distance data received from the 

Magicbit Tiny board into visual representations. 

o Through graphical elements, such as lines and shapes, the system 

illustrates the presence and position of objects detected by the radar. 

3. Real-time Monitoring: 

o As the Magicbit Tiny Radar operates, it continuously updates the 

displayed information, providing users with real-time insights into their 

surroundings. 

 

 

 Set-Up: 

 

o Make the set-up as the steps given below. 

o Set up Assembly guide 

https://youtu.be/MNS3io9HoHo 

https://youtu.be/MNS3io9HoHo


 

 Steps for the Program 

 

Download the Arduino Code Here 

 

Important - Install the “Ultrasonic.h’’ library to your Arduino interface 

before you run the below program. The library used for ultrasonic sensor 

with Magicbit Tiny is a custom made library. 

Download the Ultrasonic Library Here 

 

Upload this code to the Magicbit Tiny board 

 

 

 Processing Code 

o Open the processing IDE 

o Download the below code and copy the code and paste it in the 

processing IDE 

Click here to download the Code 

Note - Before uploading the processing code find out the USB port 

which Magicbit tiny board is connected using Arduino IDE and edit the 

processing code by including that. 

 

myPort = new Serial(this,”COM6”, 9600); // starts the serial communication 

 

 

Place objects near to the setup and see the radar on the display. 

 

https://drive.google.com/drive/folders/1FQjzKHD2XieMc-zusqOu2Syt4HNaRHVU?usp=sharing
https://drive.google.com/file/d/1IT_dyTb1zsi8JN8W_144Y2vLG51XoqWX/view?usp=sharing
https://drive.google.com/drive/folders/1pEzSdpqTR9CXjt8_QGXOzpI18P7TYlxE?usp=drive_link
https://drive.google.com/file/d/1hw7tb1SQdLJPeLSvE73OjtIvWi1hfEvh/view?usp=sharing
https://drive.google.com/file/d/1hw7tb1SQdLJPeLSvE73OjtIvWi1hfEvh/view?usp=sharing


 

Learning Points: 

• Sensor Integration: Gain insights into interfacing ultrasonic sensors 

with microcontrollers for distance measurement. 

• Data Visualization: Explore techniques for visualizing sensor data in 

real-time using Processing IDE. 

• Interactive Systems: Understand how to create interactive systems 

that respond to changes in sensor inputs. 

 

 

If you need the same activity in Sinhala Medium, go through the below Video. 

 

Tutorial in Sinhala -  https://youtu.be/evV3IPwXGhE 

https://youtu.be/evV3IPwXGhE
https://youtu.be/evV3IPwXGhE


 

 
 

23. Bluetooth Remote Controlling Car 
 

Create a program to control simple robotic car via Bluetooth 

 
 Expected Output 

 

o https://youtu.be/bcxtcEXkuvE

 Description 

o Welcome to the exciting world of the Magicbit Tiny Bluetooth Remote 

Control Car project! Get ready to explore how the Magicbit Tiny board can 

transform into a fun car controlled via Bluetooth. Let’s dive into the simple 

documentation and unveil the secrets of this thrilling project. The Magicbit 

Tiny Bluetooth Car project enables you to create a remote-controlled car 

using the Magicbit Tiny board and a Bluetooth module. With this project, you 

can send commands from your smartphone to control the car’s movements. 

 Components: 

1. Magicbit Tiny With Extension 

2. Bluetooth Module (HC-05 or HC-06) 

3. In-Built Motor Driver Modules in Magicbit Tiny Board 

4. Motors (2x) 

5. Chassis and Wheels 

6. Battery 

7. Mobile Phone with “Arduino Car” Application. 

 

 Arduino Car Application 

 

o  Click here to download Arduino Car mobile app 

https://youtu.be/bcxtcEXkuvE
https://youtu.be/bcxtcEXkuvE
https://play.google.com/store/apps/details?id=com.electro_tex.bluetoothcar
https://play.google.com/store/apps/details?id=com.electro_tex.bluetoothcar


 

 How it works: 

 

1. Bluetooth Communication: 

o Bluetooth module is integrated with the Magicbit Tiny board to enable 

wireless communication. The Bluetooth module receives commands 

from the paired device. 

2. Motor Control: 

o The project uses two in-built motor driver modules in Magicbit Tiny to 

control the direction of rotation of the motors. By activating specific 

motor pins, we can make the car move forward, backward, left, right, or 

stop. 

Set-Up: 

 

o Make the set-up as the steps given below. 

o Set up Assembly guide - https://youtu.be/q6y0NJX4XmA 
 

 

o Connect the “Bluetooth Module’’ to the above car structure as follows. 

 

https://youtu.be/q6y0NJX4XmA


 

 Program Code 

 

o Download Bluetooth Car Code  

 

Follow the steps below to upload example code for Roach Robot project. 

 

1. Connect Magicbit Tiny using a USB cable to a computer. 

2. Open the Arduino IDE, go to tool tab and select Board -> Magicbit Tiny 

-> MagicBit Tiny 

3. In tool tab select port -> COM<your port number> 

4. Go to file -> New Sketch and copy and paste above Arduino code 

to your new sketch and upload the code. 

 

• Pair your smartphone with the Bluetooth module. (Appeared name :- 

Tiny Car) 

• Open a Bluetooth terminal app on your smartphone. 

• Configure the buttons of the app (F’ for forward, ‘B’ for backward, ‘L’ for 

left, R’ for right, ‘S’ for stop). 

• Send commands 

a. ‘F’ for forward 

b. ‘B’ for backward 

c. ‘L’ for left 

d. ‘R’ for right 

e. ‘S’ for stop from the app to control the car. 

 

Learning Points: 

• Bluetooth Communication: Understanding wireless communication 

using Bluetooth. 

• Motor Control: Learning how to control motors for various 

movements. 

• Remote Control: Exploring the concept of remote-controlled devices. 

https://drive.google.com/file/d/1ZclH1rl3_ETBtlQRHKv7us5XtuzKuTXV/view?usp=sharing


We hope this guide has inspired you to explore the endless possibilities of 

electronics and programming. But this is just the beginning. 

 

 

 

 

 

 

 

 

You’ve now unlocked the 

power of Magicbit Tiny 

and Arduino! 


